Reading Site Related

Jun 04, 2007 00:32 # 44641

ginsterbusch *** wants to know...

Pocket HTML: Bug with lists?

Did I miss some news? Or why do the codes for ordered and unordered lists not work in the Journals section? They always get converted to standard paragraphs!

Test:

  • unordered

  • list

here it works.

Also it still works while viewing the Journal entries:

nao-journal-list-bug01.png

But after switching to the main article, the lists suddenly disappear!

nao-journal-list-bug02.png

cu, w0lf.

beards are cool. every villain has one!

This post was edited by ginsterbusch on Jun 04, 2007.

Jun 04, 2007 07:02 # 44643

null has a suggestion...

Re: Pocket HTML: Bug with lists?

I think it's because you forgot the [/li] tag after the 5th entry (the one about the price). That fixes it in the preview anyway; I didn't dare to edit & post in your journal without asking first.

(By the way, bold text is [b], not [strong].)

When life hands you a lemon, that's 40% of your RDA of vitamin C taken care of.

Jun 04, 2007 09:14 # 44646

ginsterbusch *** replies...

Re: Pocket HTML: Bug with lists?

I think it's because you forgot the

tag after the 5th entry (the one about the price). That fixes it in the preview anyway

Strange. So why did the preview display my list correctly at all? Some kind of automatic HTML tag completion?

BTW: I've fixed the code. It's working again now. Must've been too tired to recognize my mistake.

To avoid this in future, some kind of Wiki markup really would help. In DokuWiki markup you use asterisks with 2 spaces indent for unordered lists and minuses, also with 2 space indent, for ordered lists.

For a small demo, take a look at the DokuWiki syntax page. To test this feature, please (ab)use the wiki playground.

(By the way, bold text is \[b\], not \[strong\].)

If you're used to proper semantic (X)HTML code like me, you're using strong and emphatize to mark up your text, not bold and italic, which is HTML 4.01, deprecated code ;)

cu, w0lf.

beards are cool. every villain has one!

This post was edited by ginsterbusch on Jun 04, 2007.

Jun 04, 2007 15:58 # 44655

null replies...

Re: Pocket HTML: Bug with lists?

Strange. So why did the preview display my list correctly at all?

I have no idea. Maybe a slight difference in the PTHML-->HTML code in preview / post mode.

you're using strong and emphatize to mark up your text, not bold and italic, which is HTML 4.01, deprecated code

Good thing we're not using HTML on NAO then!

When life hands you a lemon, that's 40% of your RDA of vitamin C taken care of.


Small text Large text

Netalive Amp (Skin for Winamp)